编程知识 cdmana.com

Android 解决Android studio4.1.1不适配ButterKnife的问题(已解决可以获取控件但是报空指针的问题)

前言

解决4.1.1版本butterknife无法使用的问题

适配

在这里插入图片描述
上图中是以前在3.x版本中使用的ButterKnife,但是它并不适配4.1.1版本,所以我们需要下载另一个,如图:在这里插入图片描述
下载安装完成后,你就会发现你的ButterKnife还是不能用(狗头)。这时候我们需要改一下插件的路径。
4.1.1版本的保存路径和以前版本的不太一样,3.x及之前的都是保存在用户根目录里的,而4.1.1的路径是在C:\Users\Administrator\AppData\Local\Google\AndroidStudio4.1,AppData是隐藏文件夹,找不到的直接向文件资源管理器贴路径就完事了(Administrator是电脑的名字,Users在C盘中显示的是‘用户’)。找到下图的文件夹,这是studio存放插件的地方。在这里插入图片描述


剪切下图的jar包
在这里插入图片描述
注意!要将文件夹中下载的其他的ButterKnife全部删除,不然会出一些奇奇怪怪的错误(具体我也不知道是什么)。
将剪切后的jar包移动到下图的文件夹(这是你Android Studio的安装目录)在这里插入图片描述
做到这你的ButterKnife已经装好了,只需要再配置一下,在你的项目gradle中加入依赖



android {
   
   
  compileOptions {
   
   
        sourceCompatibility JavaVersion.VERSION_1_8
        targetCompatibility JavaVersion.VERSION_1_8
    }
}
dependencies {
   
   
implementation 'com.jakewharton:butterknife:10.2.3'
}

重启一下studio就可以使用了

补充:butterKnife获得控件空指针问题

将导入的依赖改为:

 api 'com.jakewharton:butterknife:10.2.3'
 annotationProcessor 'com.jakewharton:butterknife-compiler:10.2.3'

Annotation Processing Tool(APT)即注解处理器

版权声明
本文为[osc_81ub7i61]所创,转载请带上原文链接,感谢
https://my.oschina.net/u/4350128/blog/4836577

Scroll to Top