编程知识 cdmana.com

The dart and flutter plug-ins installed in Android studio 4.1 are not detected by the router doctor

Due to work needs , Need to use Flutter Develop the relevant environment . stay Mac Installation on Flutter When developing the environment ,flutter doctor Can't detect AndroidStudio4.1 Installed plug-ins :

 

After inquiry, we know that Android Studio  4.1 The location of the plug-in has been changed to ~/Library/Application\ Support/Google/AndroidStudio4.1/plugins, The position of the old version is ~/Library/Application\ Support/AndroidStudio4.1, So use flutter doctor When this command goes to detect , Or will go to the original location to find these two plug-ins , As a result, the plug-in cannot be found .

terms of settlement : Add soft link , The order is as follows :

ln -s ~/Library/Application\ Support/Google/AndroidStudio4.1/plugins ~/Library/Application\ Support/AndroidStudio4.1

Do it again when it's done flutter doctor The test passed :

 

The same thing happens in windows Under the circumstances :

terms of settlement :

Flutter Doctor: Android Studio 4.1 is not detected

 

meanwhile , Due to the use of my development environment JDK by JDK11 edition , Lead to flutter Report the following error :

Exception in thread "main" java.lang.NoClassDefFoundError: javax/xml/bind/annotation/XmlSchema
        at com.android.repository.api.SchemaModule$SchemaModuleVersion.<init>(SchemaModule.java:156)
        at com.android.repository.api.SchemaModule.<init>(SchemaModule.java:75)
        at com.android.sdklib.repository.AndroidSdkHandler.<clinit>(AndroidSdkHandler.java:81)
        at com.android.sdklib.tool.sdkmanager.SdkManagerCli.main(SdkManagerCli.java:73)
        at com.android.sdklib.tool.sdkmanager.SdkManagerCli.main(SdkManagerCli.java:48)
Caused by: java.lang.ClassNotFoundException: javax.xml.bind.annotation.XmlSchema
        at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:583)
        at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
        ... 5 more









terms of settlement : install Flutter Environment encounter Android license status unknown Problem solving , Support Java9,Java10,Java11

 

版权声明
本文为[_scroll]所创,转载请带上原文链接,感谢

Scroll to Top